Closed: Wifi not detected on TAILS (1 Viewer)

Miz Redavni

Non-Member
Mar 2, 2015
1,040
Elsewhere
I currently have TAILS running on my Asus TP500L series.

My Netwok controller is a MEDIATEK 7630.

And rfkill unblock all isn't working in terminal.

Any suggestions on how to fix this issue with no internet access(because wireless isn't working which is the point of this thread and I have no extra Ethernet cables)?
 
Last edited:

Kirbz

Clan Founder
Apr 14, 2012
5,967
Bethlehem PA
Clan Rank
Clan Founder
Clan Founder
is the card working as intended?

ifconfig -a

will show you active/inactive interfaces

there should be some thing related to eth0 and/or wlan and lo

not sure of how supportive tails is to that network card but that'd be my first step to see if there are interfaces.

if not you may need to find drivers and move them to the tails machine.
 

Miz Redavni

Non-Member
Mar 2, 2015
1,040
Elsewhere
is the card working as intended?

ifconfig -a

will show you active/inactive interfaces

there should be some thing related to eth0 and/or wlan and lo

not sure of how supportive tails is to that network card but that'd be my first step to see if there are interfaces.

if not you may need to find drivers and move them to the tails machine.
"bash: ifconfig-a: command not found"
 

Kirbz

Clan Founder
Apr 14, 2012
5,967
Bethlehem PA
Clan Rank
Clan Founder
Clan Founder
aslo make sure netwroking is on

/etc/init.d/networking restart

theres a few ways to do the above

sometimes just

service network start/stop/restart works too . obviously depends on versions
 

Miz Redavni

Non-Member
Mar 2, 2015
1,040
Elsewhere
does

ip a

work?

not used to seeing something without ifconfig
1: lo: <LOOPBACK, UP, LOWER_UP> mtu 65536 qdisc noqueue state UNKOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 : : 1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER, BROADCAST, MULTICAST, UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
Pretty sure the next part isn't to be shared. So a tiny bit has been cut from my quote.

aslo make sure netwroking is on

/etc/init.d/networking restart

theres a few ways to do the above

sometimes just

service network start/stop/restart works too . obviously depends on versions
Reconfiguring network interfaces... ifdown: failed to open statefiled /run/network/ifstate: Permission denied
ifup: failed to open statefile /run/network/ifstate: Permission denied
 
Last edited:

Vex

Vetted Officer
Jan 14, 2015
1,212
Clan Rank
Vetted Member
Vetted Member
[MENTION=48033]Miz Redavni[/MENTION]: Have you resolved this issue as of yet? Please quote this post

-Support staff
 

Miz Redavni

Non-Member
Mar 2, 2015
1,040
Elsewhere
[MENTION=51]Kirbz[/MENTION] Still willing to help me out on this?
 

ErkDog

Clan Member
Jun 7, 2015
118
Richmond, VA
Clan Rank
Sergeant Major of the Army
Sergeant Major

Of the Army
The command you were asked to type is "ifconfig -a" that does not equal "ifconfig-a"

Additionally, I would wonder why you are trying to run TAILS in the first place.

What specific application or usage requirement do you have that makes it so you need to run that?

There are probably a few other more actively maintained solutions that would not have a driver or compatibility issue with your hardware.

Thanks,
Matt
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Thread starter Similar threads Forum Replies Date
Wollla Closed Support Cases 4
loucetios Closed Support Cases 10